Discussion:
Signal 11 problem..
(too old to reply)
Stephen Bungay
2007-04-10 18:02:14 UTC
Permalink
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I have
not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?

I'm using gambas 1.9.47 on FC5 and FC6.

Steve.
sbungay
2007-04-10 18:17:16 UTC
Permalink
Note. The compiled app vanishes with no error messages, howeverm,
when running from within the IDE I get the "Signal 11" message.

Steve.
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I have
not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gambas-user mailing list
https://lists.sourceforge.net/lists/listinfo/gambas-user
Laurent Carlier
2007-04-10 18:21:45 UTC
Permalink
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I have
not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?

Otherwise can you run the project inside gdb and post the backtrace ? or post
the project ....

Thanks !
sbungay
2007-04-10 18:40:07 UTC
Permalink
Post by Laurent Carlier
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I have
not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?
Otherwise can you run the project inside gdb and post the backtrace ? or post
the project ....
Thanks !
I have not tried reproduce the problem within the drag and drop
example. I will do so, a question to you Laurent; by "run the project
inside the gdb" do you mean load gambas up in gambas, run it and then
load the app in that?
Post by Laurent Carlier
------------------------------------------------------------------------
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
------------------------------------------------------------------------
_______________________________________________
Gambas-user mailing list
https://lists.sourceforge.net/lists/listinfo/gambas-user
Laurent Carlier
2007-04-10 19:14:51 UTC
Permalink
Post by sbungay
Post by Laurent Carlier
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I
have not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?
Otherwise can you run the project inside gdb and post the backtrace ? or
post the project ....
Thanks !
I have not tried reproduce the problem within the drag and drop
example. I will do so, a question to you Laurent; by "run the project
inside the gdb" do you mean load gambas up in gambas, run it and then
load the app in that?
gdb is the Gnu Project Debugger http://sourceware.org/gdb/ , i guess a package
should exist for you linux distro :-)

How to you gdb to get a backtrace :
- Open a terminal (konsole, xterm, ...)
- Go in the source directory of you project ( cd ~/mygambasproject )
- Run gdb with gbx2 ( gdb gbx2 )
- Inside gdb, execute gbx2 with componant preloading ( run -p )
- Use you app and try to reproduce the bug, when a problem occur, gdb will
catch the failure.
- Produce the backtrace ( bt)
- Do a copy and Past the result here :-)

++

-
Benoit Minisini
2007-04-10 19:16:23 UTC
Permalink
Post by sbungay
Post by Laurent Carlier
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I
have not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?
Otherwise can you run the project inside gdb and post the backtrace ? or
post the project ....
Thanks !
I have not tried reproduce the problem within the drag and drop
example. I will do so, a question to you Laurent; by "run the project
inside the gdb" do you mean load gambas up in gambas, run it and then
load the app in that?
First, you must tell your shell to allow coredumps with the following command:
$ ulimit -c 32000

Then you can run the drag & drop program inside this shell, until you succeed
in crashing it.

Then you will get a core dump file named core.XXXX where XXXX is the process
id of the crashed program.

Then you can run gdb on it to find where it crashed, this way:

$ gdb /usr/bin/gbx2 core.XXXX
...

gdb will tell you exactly where the program crashed. Send me this information!

Regards,
--
Benoit Minisini
sbungay
2007-04-10 19:53:52 UTC
Permalink
Results of gdb are attached.
Post by Benoit Minisini
Post by sbungay
Post by Laurent Carlier
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I
have not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?
Otherwise can you run the project inside gdb and post the backtrace ? or
post the project ....
Thanks !
I have not tried reproduce the problem within the drag and drop
example. I will do so, a question to you Laurent; by "run the project
inside the gdb" do you mean load gambas up in gambas, run it and then
load the app in that?
$ ulimit -c 32000
Then you can run the drag & drop program inside this shell, until you succeed
in crashing it.
Then you will get a core dump file named core.XXXX where XXXX is the process
id of the crashed program.
$ gdb /usr/bin/gbx2 core.XXXX
...
gdb will tell you exactly where the program crashed. Send me this information!
Regards,
Benoit Minisini
2007-04-10 21:16:21 UTC
Permalink
Post by sbungay
Results of gdb are attached.
Post by Benoit Minisini
Post by sbungay
Post by Laurent Carlier
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no
error message) with a signal 11 while performing drag and drop
operations. I have not been able to ascertain any kind of pattern to
the failures. The application might perform wonderfully for three or
four drag & drops and suddenly fail on the initiation of a drag or on
the drop event. Has anyone else experienced failures of this type when
using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?
Otherwise can you run the project inside gdb and post the backtrace ? or
post the project ....
Thanks !
I have not tried reproduce the problem within the drag and drop
example. I will do so, a question to you Laurent; by "run the project
inside the gdb" do you mean load gambas up in gambas, run it and then
load the app in that?
First, you must tell your shell to allow coredumps with the following
command: $ ulimit -c 32000
Then you can run the drag & drop program inside this shell, until you
succeed in crashing it.
Then you will get a core dump file named core.XXXX where XXXX is the
process id of the crashed program.
$ gdb /usr/bin/gbx2 core.XXXX
...
gdb will tell you exactly where the program crashed. Send me this information!
Regards,
I forgot to tell you to run the 'bt' command in gdb so that you get the stack
trace. This is what I need.

Regards,
--
Benoit Minisini
sbungay
2007-04-10 22:48:58 UTC
Permalink
Post by Benoit Minisini
Post by sbungay
Results of gdb are attached.
Post by Benoit Minisini
Post by sbungay
Post by Laurent Carlier
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no
error message) with a signal 11 while performing drag and drop
operations. I have not been able to ascertain any kind of pattern to
the failures. The application might perform wonderfully for three or
four drag & drops and suddenly fail on the initiation of a drag or on
the drop event. Has anyone else experienced failures of this type when
using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?
Otherwise can you run the project inside gdb and post the backtrace ? or
post the project ....
Thanks !
I have not tried reproduce the problem within the drag and drop
example. I will do so, a question to you Laurent; by "run the project
inside the gdb" do you mean load gambas up in gambas, run it and then
load the app in that?
First, you must tell your shell to allow coredumps with the following
command: $ ulimit -c 32000
Then you can run the drag & drop program inside this shell, until you
succeed in crashing it.
Then you will get a core dump file named core.XXXX where XXXX is the
process id of the crashed program.
$ gdb /usr/bin/gbx2 core.XXXX
...
gdb will tell you exactly where the program crashed. Send me this information!
Regards,
I forgot to tell you to run the 'bt' command in gdb so that you get the stack
trace. This is what I need.
Regards,
Benoit Minisini
2007-04-11 07:32:07 UTC
Permalink
Post by sbungay
Results of gdb are attached.
Post by Stephen Bungay
I have an application which makes use of drag and drop and
occasionally Gambas fails (entire compiled app vanishes from the
screen with no error message) with a signal 11 while performing drag
and drop operations. I have not been able to ascertain any kind of
pattern to the failures. The application might perform wonderfully
for three or four drag & drops and suddenly fail on the initiation
of a drag or on the drop event. Has anyone else experienced failures
of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
I just uploaded a fix to the svn trunk. Can you try it?

But I'm not sure it will solve the bug. The better would be that you send me
your project so that I can debug it.

Regards,
--
Benoit Minisini
sbungay
2007-04-11 12:38:37 UTC
Permalink
Will try this first and let you know.
Might not be able to test until later this morning. Your time-zone is 6
hours ahead of me.
Send project to '***@users.sourceforge.net'? I wouldn't want to
send the project to the list.

Steve.
Post by Benoit Minisini
Post by sbungay
Results of gdb are attached.
Post by Stephen Bungay
I have an application which makes use of drag and drop and
occasionally Gambas fails (entire compiled app vanishes from the
screen with no error message) with a signal 11 while performing drag
and drop operations. I have not been able to ascertain any kind of
pattern to the failures. The application might perform wonderfully
for three or four drag & drops and suddenly fail on the initiation
of a drag or on the drop event. Has anyone else experienced failures
of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
I just uploaded a fix to the svn trunk. Can you try it?
But I'm not sure it will solve the bug. The better would be that you send me
your project so that I can debug it.
Regards,
Benoit Minisini
2007-04-11 22:19:44 UTC
Permalink
Post by sbungay
Will try this first and let you know.
Might not be able to test until later this morning. Your time-zone is 6
hours ahead of me.
You can, this is my private sourceforge e-mail.

Regards,
--
Benoit Minisini
sbungay
2007-04-10 19:17:26 UTC
Permalink
It seems to be the 'delete' method of the dynamically created
controls that is causing the problem.
Post by Laurent Carlier
Post by Stephen Bungay
I have an application which makes use of drag and drop and occasionally
Gambas fails (entire compiled app vanishes from the screen with no error
message) with a signal 11 while performing drag and drop operations. I have
not been able to ascertain any kind of pattern to the failures. The
application might perform wonderfully for three or four drag & drops and
suddenly fail on the initiation of a drag or on the drop event.
Has anyone else experienced failures of this type when using drag & drop?
I'm using gambas 1.9.47 on FC5 and FC6.
Steve.
Can you reproduce the failure with the drag and drop example ?
Otherwise can you run the project inside gdb and post the backtrace ? or post
the project ....
Thanks !
------------------------------------------------------------------------
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
------------------------------------------------------------------------
_______________________________________________
Gambas-user mailing list
https://lists.sourceforge.net/lists/listinfo/gambas-user
Loading...