Discussion:
Ok, what have I done?
(too old to reply)
Kadaitcha Man
2009-12-02 09:09:08 UTC
Permalink
This happens in both Gambas 2.18 and 3.

When I drag a hSplit or a vSplit onto a form, I can't add any controls
to either the left or the right panel because the splitter is not
functioning.

Anyone got any suggestions?
Benoît Minisini
2009-12-02 13:52:39 UTC
Permalink
Post by Kadaitcha Man
This happens in both Gambas 2.18 and 3.
When I drag a hSplit or a vSplit onto a form, I can't add any controls
to either the left or the right panel because the splitter is not
functioning.
Anyone got any suggestions?
I'm not sure to really understand what you are talking about there...
--
Benoît Minisini
Kadaitcha Man
2009-12-02 20:00:25 UTC
Permalink
Post by Benoît Minisini
Post by Kadaitcha Man
This happens in both Gambas 2.18 and 3.
When I drag a hSplit or a vSplit onto a form, I can't add any controls
to either the left or the right panel because the splitter is not
functioning.
Anyone got any suggestions?
I'm not sure to really understand what you are talking about there...
Oh. I thought it was clear with the image I attached to the first
post. I'll try again.

Either I am missing some fundamental point about hSplit and vSplit or
something is wrong.

There is no sign of a splitter in the design environment on either h
or vsplit so there is no way for me decide if I want to place controls
to the left or right of the splitter bar on a hsplit, or above or
below the splitter bar on a vsplit.

There is no splitter bar. There are no left and right panels and no
top and bottom panels. No splitter bar.

Does the attached image of two splitter controls look right to you? If
so, how do you add a control on the left of the splitter and one on
the right?
Benoît Minisini
2009-12-02 20:08:02 UTC
Permalink
Post by Kadaitcha Man
Post by Benoît Minisini
Post by Kadaitcha Man
This happens in both Gambas 2.18 and 3.
When I drag a hSplit or a vSplit onto a form, I can't add any controls
to either the left or the right panel because the splitter is not
functioning.
Anyone got any suggestions?
I'm not sure to really understand what you are talking about there...
Oh. I thought it was clear with the image I attached to the first
post. I'll try again.
Either I am missing some fundamental point about hSplit and vSplit or
something is wrong.
There is no sign of a splitter in the design environment on either h
or vsplit so there is no way for me decide if I want to place controls
to the left or right of the splitter bar on a hsplit, or above or
below the splitter bar on a vsplit.
There is no splitter bar. There are no left and right panels and no
top and bottom panels. No splitter bar.
Does the attached image of two splitter controls look right to you? If
so, how do you add a control on the left of the splitter and one on
the right?
Ok! Just put some controls inside the H/VSlider, and at run time it will
display it from left to right (or top to bottom) with sliders between them.

Regards,
--
Benoît Minisini
Kadaitcha Man
2009-12-03 07:27:06 UTC
Permalink
Post by Benoît Minisini
Ok! Just put some controls inside the H/VSlider, and at run time it will
display it from left to right (or top to bottom) with sliders between them.
Aaaah, crikey, hey.

lol

I will make a note to make sure that behaviour is documented. I've
spent far too much time in Visual Studio.

Thank you.
Matteo Lisi
2009-12-03 10:24:15 UTC
Permalink
Hi to ALL !

This is my situation:

I have a ARM sistem with gambas installed, and I want to debug it from a
PC (I have to develop a new IDE.......)

How gambas IDE use the interpreter for debug ?

I thought to develop a service on ARM that via TCP/IP link the ARM
gambas interpreter with a PC IDE.

What do you think about this solution ?

Thanks to all !!
Benoît Minisini
2009-12-03 22:15:49 UTC
Permalink
Post by Matteo Lisi
Hi to ALL !
I have a ARM sistem with gambas installed, and I want to debug it from a
PC (I have to develop a new IDE.......)
How gambas IDE use the interpreter for debug ?
I thought to develop a service on ARM that via TCP/IP link the ARM
gambas interpreter with a PC IDE.
What do you think about this solution ?
Thanks to all !!
Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?

Otherwise, can you explain exactly what you want to do? What do you want to
debug: The interpreter? A Gambas project? The IDE?...
--
Benoît Minisini
Ricardo Díaz Martín
2009-12-04 07:13:14 UTC
Permalink
I use google acount with web interface and I can see his emails right
Post by Benoît Minisini
Post by Matteo Lisi
Hi to ALL !
I have a ARM sistem with gambas installed, and I want to debug it from a
PC (I have to develop a new IDE.......)
How gambas IDE use the interpreter for debug ?
I thought to develop a service on ARM that via TCP/IP link the ARM
gambas interpreter with a PC IDE.
What do you think about this solution ?
Thanks to all !!
Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?
Otherwise, can you explain exactly what you want to do? What do you want to
debug: The interpreter? A Gambas project? The IDE?...
--
Benoît Minisini
------------------------------------------------------------------------------
Join us December 9, 2009 for the Red Hat Virtual Experience,
a free event focused on virtualization and cloud computing.
Attend in-depth sessions from your desk. Your couch. Anywhere.
http://p.sf.net/sfu/redhat-sfdev2dev
_______________________________________________
Gambas-user mailing list
https://lists.sourceforge.net/lists/listinfo/gambas-user
Jean-Yves F. Barbier
2009-12-04 07:22:51 UTC
Permalink
Post by Benoît Minisini
Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?
I use idedove (thunderbird) and see them ok (however he's cross-posting...)
--
coitus interruptus, n:
A jerky movement following the words (by either sex partner)
"I want to have your child."
Matteo Lisi
2009-12-04 08:44:41 UTC
Permalink
Hi !
I try to explain better:
I have a ARM system with gambas installed (gbc2 gbx2 gbi2 ecc... ecc.. but
NOT IDE) and I want run in a gambas project.
This gambas project must be written on a PC system (windows Based ) and then
deploy on the ARM system, and for do this I need to develop a new IDE with
new functions for manage this configuration.
On the ARM system I have to compile and execute the gambas project written
on PC system. But if I want also debug the project on the ARM system and
then have the debug control from the PC system what I have to do ?
I have a TCP/IP connection from PC system and ARM system with ftp and ssh
services enabled.
I thought to develop a service on ARM system for link my IDE on the PC
system with gambas interpreter , but How I can manage the debug with the
interpreter ?
Have you some ideas ?
Regards and thanks for all you reply...
Benoît Minisini ha scritto:

Hi to ALL !

This is my situation:

I have a ARM sistem with gambas installed, and I want to debug it from a
PC (I have to develop a new IDE.......)

How gambas IDE use the interpreter for debug ?

I thought to develop a service on ARM that via TCP/IP link the ARM
gambas interpreter with a PC IDE.

What do you think about this solution ?

Thanks to all !!



Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?

Otherwise, can you explain exactly what you want to do? What do you want to
debug: The interpreter? A Gambas project? The IDE?...
Benoît Minisini
2009-12-04 13:57:55 UTC
Permalink
Post by Matteo Lisi
Hi !
I have a ARM system with gambas installed (gbc2 gbx2 gbi2 ecc... ecc..
but NOT IDE) and I want run in a gambas project.
This gambas project must be written on a PC system (windows Based ) and
then deploy on the ARM system, and for do this I need to develop a new IDE
with new functions for manage this configuration.
On the ARM system I have to compile and execute the gambas project
written on PC system. But if I want also debug the project on the ARM
system and then have the debug control from the PC system what I have to
do ? I have a TCP/IP connection from PC system and ARM system with ftp and
ssh services enabled.
I thought to develop a service on ARM system for link my IDE on the PC
system with gambas interpreter , but How I can manage the debug with the
interpreter ?
Have you some ideas ?
Regards and thanks for all you reply...
OK, I understand now.

The IDE and the debugged Gambas application communicate through two named
pipes, that are located on the same system then, in the /tmp directory.

To do that remotely, I must find a way to:

1) Run a gambas project remotely on the ARM from the PC system.

2) Let him use something else than a pipe (a socket for example).

I need help for the first point mainly!
--
Benoît Minisini
Rob
2009-12-04 18:29:33 UTC
Permalink
Post by Benoît Minisini
Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?
I've been using kmail since before version 1.0 and I've never seen these
list messages threaded at all, even though I have "Expand thread" and
"Collapse thread" options in the View menu.

Rob
Benoît Minisini
2009-12-04 23:05:18 UTC
Permalink
Post by Rob
Post by Benoît Minisini
Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?
I've been using kmail since before version 1.0 and I've never seen these
list messages threaded at all, even though I have "Expand thread" and
"Collapse thread" options in the View menu.
Rob
Oops, I said "never" instead of "always". Apparently, KMail receives new
Matteo's threads, and attach them to a non-related thread. No idea why...
--
Benoît Minisini
Ron_1st
2009-12-05 01:25:45 UTC
Permalink
Post by Benoît Minisini
Post by Rob
Post by Benoît Minisini
Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?
I've been using kmail since before version 1.0 and I've never seen these
list messages threaded at all, even though I have "Expand thread" and
"Collapse thread" options in the View menu.
Rob
Oops, I said "never" instead of "always". Apparently, KMail receives new
Matteo's threads, and attach them to a non-related thread. No idea why...
Look in the headers.


Received: by vws35 with SMTP id 35so455862vws.4
        for <gambas-***@lists.sourceforge.net>;
        Wed, 02 Dec 2009 23:27:06 -0800 (PST)
MIME-Version: 1.0
Received: by 10.220.121.155 with SMTP id h27mr1482265vcr.20.1259825226532;
        Wed, 02 Dec 2009 23:27:06 -0800 (PST)
In-Reply-To: <***@users.sourceforge.net>
References: <***@mail.gmail.com>
        <***@users.sourceforge.net>
        <***@mail.gmail.com>
        <***@users.sourceforge.net>
Date: Thu, 3 Dec 2009 18:27:06 +1100
Message-ID: <***@mail.gmail.com>
From: Kadaitcha Man <***@gmail.com>
To: mailing list for gambas users <gambas-***@lists.sourceforge.net>

[[[ note : Message-ID: <***@mail.gmail.com> ]]]



Received: from unknown (HELO ?192.168.2.123?)
        (***@engicam.com@85.39.149.113)
        by smtp3.aruba.it with SMTP; 3 Dec 2009 10:24:28 -0000
Message-ID: <***@engicam.com>
Date: Thu, 03 Dec 2009 11:24:15 +0100
From: Matteo Lisi <***@engicam.com>
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
To: mailing list for gambas users <gambas-***@lists.sourceforge.net>
References: <***@mail.gmail.com>   <***@users.sourceforge.net>       <***@mail.gmail.com>   <***@users.sourceforge.net>
        <***@mail.gmail.com>
In-Reply-To: <***@mail.gmail.com>
X-Spam-Rating: smtp3.aruba.it 1.6.2 0/1000/N
X-Spam-Score: 0.0 (/)
X-Spam-Report: Spam Filtering performed by mx.sourceforge.net.
        See http://spamassassin.org/tag/ for more details. _SUMMARY_
X-Headers-End: 1NG8rV-0005TO-Ls
Subject: [Gambas-user] Gambas Remotly Debug
X-BeenThere: gambas-***@lists.sourceforge.net

[[[ ote : In-Reply-To: <***@mail.gmail.com> ]]]


So I think/belive he is always using 'Reply' instead of 'New Message'


For Matteo Lisi:

When people close a thread i.e. '[Gambas-user] Ok, what have I done? in
the message three they do not see always new messages apear.
Second it is not of others/my interest to continue to read that thread anymore.
By a reply on that thread your message wil be lost for others/me.
In other words. you are limmiting the count of readers for your question.

If you have a new question or other message always start with a new
to get attention of the readers.




Best regards,

Ron_1st

--
Ron_1st
2009-12-05 01:36:16 UTC
Permalink
Post by Benoît Minisini
Post by Rob
Post by Benoît Minisini
Your new threads are never attached to another non-related thread when I
receive them. Why? I use KMail: do other people see the same thing than me?
I've been using kmail since before version 1.0 and I've never seen these
list messages threaded at all, even though I have "Expand thread" and
"Collapse thread" options in the View menu.
Rob
Oops, I said "never" instead of "always". Apparently, KMail receives new
Matteo's threads, and attach them to a non-related thread. No idea why...
I confirm this for 'always' and using kmail too :)


Best regards,

Ron_1st

--

Loading...