Discussion:
[Gambas Bug Tracker] Bug #1127: please switch to libsecret from keyring
(too old to reply)
b***@gambaswiki.org
2017-07-10 16:24:37 UTC
Permalink
http://gambaswiki.org/bugtracker/edit?object=BUG.1127&from=L21haW4-

Gianfranco COSTAMAGNA reported a new bug.

Summary
-------

please switch to libsecret from keyring

Type : Bug
Priority : Medium
Gambas version : Unknown
Product : Unknown


Description
-----------

taken from http://bugs.debian.org/867930
Hi,

The libgnome-keyring library is deprecated and its usage is strongly
discouraged [1].

Your package gambas3 declares a build-dependency on
libgnome-keyring-dev or links against libgnome-keyring0.

Please update your application to use libsecret instead [2].
Such a port should ideally happen with upstream being involved.

On behalf of the Debian GNOME team,
Michael Biebl

[1] https://git.gnome.org/browse/libgnome-keyring/commit/?id=6a5adea4aec93
[2] https://wiki.gnome.org/Projects/Libsecret
b***@gambaswiki.org
2017-07-10 16:33:50 UTC
Permalink
http://gambaswiki.org/bugtracker/edit?object=BUG.1127&from=L21haW4-

Benoît MINISINI changed the state of the bug to: Accepted.
b***@gambaswiki.org
2017-07-10 16:53:42 UTC
Permalink
http://gambaswiki.org/bugtracker/edit?object=BUG.1127&from=L21haW4-

Comment #1 by Benoît MINISINI:

I deprecated the 'gb.desktop.gnome' component, and do not use it anymore. Is it enough for debian?

After all, you don't have to compile all the components to compile Gambas.

Benoît MINISINI changed the state of the bug to: NeedsInfo.
b***@gambaswiki.org
2017-07-10 18:09:37 UTC
Permalink
http://gambaswiki.org/bugtracker/edit?object=BUG.1127&from=L21haW4-

Comment #2 by PICCORO LENZ MCKAY:

the requirements for libsecret are very high, with only removal of gnome related its just fine..
Continue reading on narkive:
Loading...